ABOUT ME

-

Today
-
Yesterday
-
Total
-
  • Plus Minus
    개발 모음집/HackerRank 2021. 1. 17. 20:54

    Given an array of integers, calculate the ratios of its elements that are positive, negative, and zero. Print the decimal value of each fraction on a new line with  places after the decimal.

    Note: This challenge introduces precision problems. The test cases are scaled to six decimal places, though answers with absolute error of up to  are acceptable.

    Example

    There are  elements, two positive, two negative and one zero. Their ratios are ,  and . Results are printed as:

    0.400000 0.400000 0.200000

    Function Description

    Complete the plusMinus function in the editor below.

    plusMinus has the following parameter(s):

    • int arr[n]: an array of integers

    Print
    Print the ratios of positive, negative and zero values in the array. Each value should be printed on a separate line with  digits after the decimal. The function should not return a value.

    Input Format

    The first line contains an integer, , the size of the array.
    The second line contains  space-separated integers that describe .

    Constraints


    Output Format

    Print the following  lines, each to  decimals:

    1. proportion of positive values
    2. proportion of negative values
    3. proportion of zeros

    Sample Input

    6 -4 3 -9 0 4 1

    Sample Output

    0.500000 0.333333 0.166667

     

    #!/bin/python3
    
    import math
    import os
    import random
    import re
    import sys
    
    # Complete the plusMinus function below.
    def plusMinus(arr):
        positive_num = 0
        negative_num = 0
        zero_num = 0
        total_len = len(arr)
        for i in arr:
            if i > 0:
                positive_num += 1
            elif i < 0:
                negative_num += 1
            else:
                zero_num += 1
        print(round(positive_num / total_len , 6))
        print(round(negative_num / total_len, 6))
        print(round(zero_num / total_len, 6))
    
    if __name__ == '__main__':
        n = int(input())
    
        arr = list(map(int, input().rstrip().split()))
    
        plusMinus(arr)
    

    '개발 모음집 > HackerRank' 카테고리의 다른 글

    Time Conversion  (0) 2021.01.17
    Birthday Cake Candles  (0) 2021.01.17
    Mini-Max Sum  (0) 2021.01.17
    Staircase  (0) 2021.01.17
    Diagonal Difference  (0) 2021.01.17
    A Very Big Sum  (0) 2021.01.17
    Compare the Triplets  (0) 2021.01.17
    Simple Array Sum  (0) 2021.01.17
Designed by Tistory.