ABOUT ME

-

Today
-
Yesterday
-
Total
-
  • Simple Array Sum
    개발 모음집/HackerRank 2021. 1. 17. 20:46

    Given an array of integers, find the sum of its elements.

    For example, if the array , , so return .

    Function Description

    Complete the simpleArraySum function in the editor below. It must return the sum of the array elements as an integer.

    simpleArraySum has the following parameter(s):

    • ar: an array of integers

    Input Format

    The first line contains an integer, , denoting the size of the array.
    The second line contains  space-separated integers representing the array's elements.

    Constraints

     

    Output Format

    Print the sum of the array's elements as a single integer.

    Sample Input

    6 1 2 3 4 10 11

    Sample Output

    31

    Explanation

    We print the sum of the array's elements:1+2+3+4+10+11=31

    #!/bin/python3
    
    import os
    import sys
    
    #
    # Complete the simpleArraySum function below.
    #
    def simpleArraySum(ar):
        #
        # Write your code here.
        #
        result = 0
        for data in ar:
            result += data
        return result
    
    if __name__ == '__main__':
        fptr = open(os.environ['OUTPUT_PATH'], 'w')
    
        ar_count = int(input())
    
        ar = list(map(int, input().rstrip().split()))
    
        result = simpleArraySum(ar)
    
        fptr.write(str(result) + '\n')
    
        fptr.close()
    

    '개발 모음집 > HackerRank' 카테고리의 다른 글

    Birthday Cake Candles  (0) 2021.01.17
    Mini-Max Sum  (0) 2021.01.17
    Staircase  (0) 2021.01.17
    Plus Minus  (0) 2021.01.17
    Diagonal Difference  (0) 2021.01.17
    A Very Big Sum  (0) 2021.01.17
    Compare the Triplets  (0) 2021.01.17
    Solve Me First  (0) 2021.01.17
Designed by Tistory.