본문 바로가기
Engineering WIKI/HackerRank

Birthday Cake Candles

by wonos 2021. 1. 17.

You are in charge of the cake for a child's birthday. You have decided the cake will have one candle for each year of their total age. They will only be able to blow out the tallest of the candles. Count how many candles are tallest.

Example

 

The maximum height candles are  units high. There are  of them, so return .

Function Description

Complete the function birthdayCakeCandles in the editor below.

birthdayCakeCandles has the following parameter(s):

  • int candles[n]: the candle heights

Returns

  • int: the number of candles that are tallest

Input Format

The first line contains a single integer, , the size of .
The second line contains  space-separated integers, where each integer  describes the height of .

Constraints

  •  
  •  

Sample Input 0

4 3 2 1 3

Sample Output 0

2

#!/bin/python3

import math
import os
import random
import re
import sys
from collections import Counter

#
# Complete the 'birthdayCakeCandles' function below.
#
# The function is expected to return an INTEGER.
# The function accepts INTEGER_ARRAY candles as parameter.
#

def birthdayCakeCandles(candles):
    count_candles = Counter(candles).most_common(1)
    print(count_candles)
    max_candles = count_candles[0]
    return max_candles[1]

if __name__ == '__main__':
    fptr = open(os.environ['OUTPUT_PATH'], 'w')

    candles_count = int(input().strip())

    candles = list(map(int, input().rstrip().split()))

    result = birthdayCakeCandles(candles)

    fptr.write(str(result) + '\n')

    fptr.close()

'Engineering WIKI > HackerRank' 카테고리의 다른 글

Time Conversion  (0) 2021.01.17
Mini-Max Sum  (0) 2021.01.17
Staircase  (0) 2021.01.17
Plus Minus  (0) 2021.01.17
Diagonal Difference  (0) 2021.01.17
A Very Big Sum  (0) 2021.01.17
Compare the Triplets  (0) 2021.01.17
Simple Array Sum  (0) 2021.01.17