-
Time ConversionEngineering WIKI/HackerRank 2021. 1. 17. 21:01
Given a time in -hour AM/PM format, convert it to military (24-hour) time.
Note: - 12:00:00AM on a 12-hour clock is 00:00:00 on a 24-hour clock.
- 12:00:00PM on a 12-hour clock is 12:00:00 on a 24-hour clock.Example
-
Return '12:01:00'.
-
Return '00:01:00'.
Function Description
Complete the timeConversion function in the editor below. It should return a new string representing the input time in 24 hour format.
timeConversion has the following parameter(s):
- string s: a time in hour format
Returns
- string: the time in hour format
Input Format
A single string that represents a time in -hour clock format (i.e.: or ).
Constraints
- All input times are valid
Sample Input 0
07:05:45PM
Sample Output 0
19:05:45
#!/bin/python3 import os import sys # # Complete the timeConversion function below. # def timeConversion(s): stand = 12 tmp_str = int(s[:2]) if(s[-2:] == "PM"): if(tmp_str == stand): return s[:-2] tmp_str = stand + tmp_str result = str(tmp_str) + s[2:-2] return result else: if(tmp_str == stand): tmp_str = "00" result = str(tmp_str) + s[2:-2] return result else: return s[:-2] if __name__ == '__main__': f = open(os.environ['OUTPUT_PATH'], 'w') s = input() result = timeConversion(s) f.write(result + '\n') f.close()
'Engineering WIKI > HackerRank' 카테고리의 다른 글
Birthday Cake Candles (0) 2021.01.17 Mini-Max Sum (0) 2021.01.17 Staircase (0) 2021.01.17 Plus Minus (0) 2021.01.17 Diagonal Difference (0) 2021.01.17 A Very Big Sum (0) 2021.01.17 Compare the Triplets (0) 2021.01.17 Simple Array Sum (0) 2021.01.17 -